IPB

Welcome Guest ( Log In | Register )

 
 
Reply to this topicStart new topic
> Fuel pump keeps running, Fuel pump keeps running after ignition is turned off
lexus914
post Jul 16 2017, 06:38 PM
Post #1


Newbie
*

Group: Members
Posts: 16
Joined: April 11, 2013
Member No.: 27,022



My 1973 914 2 liter is running great thanks to DR914 and his advice . Now, however, the fuel pump keeps running after I turn off the ignition. The fuel pressure while running is 30lbs.. and after I shut off the ignition the fuel pressure continues to be 30lbs.. but the fuel pump Will not quit running. Any ideas?
Go to the top of the page
 
+Quote Post
Dr. 914
post Jul 17 2017, 07:44 AM
Post #2


Dr. 914
****

Group: Admin
Posts: 3,167
Joined: April 12, 2010
From: Marietta, Georgia
Member No.: 20,846



Pull the fuel pump relay and see if the fuel pump stops. Could be a sticking relay. If the fuel pump continues to run with the fuel pump relay pulled, there is a misconnected wire

QUOTE (lexus914 @ Jul 16 2017, 06:38 PM) *
My 1973 914 2 liter is running great thanks to DR914 and his advice . Now, however, the fuel pump keeps running after I turn off the ignition. The fuel pressure while running is 30lbs.. and after I shut off the ignition the fuel pressure continues to be 30lbs.. but the fuel pump Will not quit running. Any ideas?

Go to the top of the page
 
+Quote Post
lexus914
post Jul 22 2017, 05:52 PM
Post #3


Newbie
*

Group: Members
Posts: 16
Joined: April 11, 2013
Member No.: 27,022



QUOTE (Dr. 914 @ Jul 17 2017, 08:44 AM) *
Pull the fuel pump relay and see if the fuel pump stops. Could be a sticking relay. If the fuel pump continues to run with the fuel pump relay pulled, there is a misconnected wire

QUOTE
My 1973 914 2 liter is running great thanks to DR914 and his advice . Now, however, the fuel pump keeps running after I turn off the ignition. The fuel pressure while running is 30lbs.. and after I shut off the ignition the fuel pressure continues to be 30lbs.. but the fuel pump Will not quit running. Any ideas?


Go to the top of the page
 
+Quote Post
lexus914
post Jul 22 2017, 05:56 PM
Post #4


Newbie
*

Group: Members
Posts: 16
Joined: April 11, 2013
Member No.: 27,022



Yep, pulled the relay added a new one and fuel pump works as it should. Thanks George. You are the doctor.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 

RSS Lo-Fi Version Time is now: September 22, 2017 - 05:44 AM